www.ndwl.net > tomCAt 8.0支持jDk8吗?

tomCAt 8.0支持jDk8吗?

tomcat 和 jdk并没有直接关系,不存在支持的问题,安装之后应该能正常工作。

从tomcat官网就可以看出对应版本的列表tomcat7需要至少1.6及其以上的jdk版本,但是你1.7的jdk就不存在说用什么版本的tomcat了,都可以用,现在最稳定的还是tomcat6

你这个问题有点模糊。 tomcat是个java应用,运行在jdk上,不是吗? tomcat8和java8安装到一起,使用是没问题的。 如果你是问对javaEE中servlet版本的支持的话,就得去官网查了。

tomcat8支持jdk1.7

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的Socket,也就是说tomcat是在jdk环境下运行的。而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.72,具体记不...

7 and later(来之官方文档):

7 and later

jdk版本的设计是向后兼容的,即高版本支持低版本,所以tomcat6支持jdk1.8的。

tomcat8支持jdk1.7,

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

网站地图

All rights reserved Powered by www.ndwl.net

copyright ©right 2010-2021。
www.ndwl.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com